# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^()]+).*/$1/gm;t' <<< "Richard H. Hoffman (60-100)
Alex S. Simmon (72-333)
Michael S. Pip (1-0)"