// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^()]+).*").unwrap();
let string = "Richard H. Hoffman (60-100)
Alex S. Simmon (72-333)
Michael S. Pip (1-0)";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}