$re = '/^([^()]+).*/m';
$str = 'Richard H. Hoffman (60-100)
Alex S. Simmon (72-333)
Michael S. Pip (1-0)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;