const regex = /^([^()]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^()]+).*', 'gm')
const str = `Richard H. Hoffman (60-100)
Alex S. Simmon (72-333)
Michael S. Pip (1-0)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);