use strict;
my $str = 'Richard H. Hoffman (60-100)
Alex S. Simmon (72-333)
Michael S. Pip (1-0)';
my $regex = qr/^([^()]+).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";