# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|[^|]*\|\S\s//gm;t' <<< "from |cffa22fc8Peachee|r others"