use strict;
my $str = 'from |cffa22fc8Peachee|r others';
my $regex = qr/\|[^|]*\|\S\s/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";