import re
regex = re.compile(r"\|[^|]*\|\S\s", flags=re.MULTILINE)
test_str = "from |cffa22fc8Peachee|r others"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)