const regex = /\|[^|]*\|\S\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|[^|]*\\|\\S\\s', 'gm')
const str = `from |cffa22fc8Peachee|r others`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);