$re = '/\|[^|]*\|\S\s/m';
$str = 'from |cffa22fc8Peachee|r others';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;