const regex = /\s*(?<!\$)\b\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?<!\\$)\\b\\d+', 'g')
const str = `This is a number 100 but this isn't \$100.`;
const subst = `!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);