$re = '/\s*(?<!\$)\b\d+/';
$str = 'This is a number 100 but this isn\'t $100.';
$subst = "!";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;