re = /\s*(?<!\$)\b\d+/
str = 'This is a number 100 but this isn\'t $100.'
subst = '!'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result