# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[^.]*?\.){2}[^.]*)\.(.*)/$1. Here I had a full stop.$2/g;t' <<< "My name is Resheil. I'm developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php."