// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:[^.]*?\.){2}[^.]*)\.(.*)").unwrap();
let string = "My name is Resheil. I'm developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php.";
let substitution = "$1. Here I had a full stop.$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}