use strict;
my $str = 'My name is Resheil. I\'m developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php.';
my $regex = qr/((?:[^.]*?\.){2}[^.]*)\.(.*)/p;
my $subst = '$1. Here I had a full stop.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";