package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^.]*?\.){2}[^.]*)\.(.*)`)
var str = `My name is Resheil. I'm developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php.`
var substitution = "$1. Here I had a full stop.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}