import Foundation
let pattern = #"((?:[^.]*?\.){2}[^.]*)\.(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"My name is Resheil. I'm developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1. Here I had a full stop.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)