import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\b(?:fees?|charges?)\\b.*$";
final String string = "fees credit card\n"
+ "charges for interest\n"
+ "coffee shop\n"
+ "eeder cattle\n\n"
+ "fee credit card\n"
+ "charge for interest\n\n"
+ "test fees credit card\n"
+ "test charge for interest\n\n"
+ "test afees credit card\n"
+ "test charged for interest\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}