import re
regex = re.compile(r"^.*\b(?:fees?|charges?)\b.*$", flags=re.MULTILINE)
test_str = ("fees credit card\n"
"charges for interest\n"
"coffee shop\n"
"eeder cattle\n\n"
"fee credit card\n"
"charge for interest\n\n"
"test fees credit card\n"
"test charge for interest\n\n"
"test afees credit card\n"
"test charged for interest\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")