$re = '/^.*\b(?:fees?|charges?)\b.*$/m';
$str = 'fees credit card
charges for interest
coffee shop
eeder cattle
fee credit card
charge for interest
test fees credit card
test charge for interest
test afees credit card
test charged for interest
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);