re = /^.*\b(?:fees?|charges?)\b.*$/m
str = 'fees credit card
charges for interest
coffee shop
eeder cattle
fee credit card
charge for interest
test fees credit card
test charge for interest
test afees credit card
test charged for interest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end