# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro/$1µ/g;t' <<< "micromicro
asdasdmicromicroasdasd
µmicro
µ
&123micro
<123 micro
asdad micro/>
micro123
123micro
µ
<micro>
<asdmicroasdad />
&asdmicro123;
µ
"