import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\G|\\n)(?:.*?&.*?micro.*?;[\\s\\S]*?|.*?<.*?micro.*?>[\\s\\S]*?|.)*?)micro";
final String string = "micromicro\n"
+ "asdasdmicromicroasdasd\n"
+ "µmicro\n"
+ "µ\n"
+ "&123micro\n"
+ "<123 micro\n"
+ "asdad micro/>\n"
+ "micro123\n"
+ "123micro\n\n"
+ "µ\n"
+ "<micro>\n"
+ "<asdmicroasdad />\n"
+ "&asdmicro123;\n"
+ "µ\n";
final String subst = "$1µ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}