# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro"
test_str = ("micromicro\n"
"asdasdmicromicroasdasd\n"
"µmicro\n"
"µ\n"
"&123micro\n"
"<123 micro\n"
"asdad micro/>\n"
"micro123\n"
"123micro\n\n"
"µ\n"
"<micro>\n"
"<asdmicroasdad />\n"
"&asdmicro123;\n"
"µ\n")
subst = "$1µ"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.