use strict;
my $str = 'micromicro
asdasdmicromicroasdasd
µmicro
µ
&123micro
<123 micro
asdad micro/>
micro123
123micro
µ
<micro>
<asdmicroasdad />
&asdmicro123;
µ
';
my $regex = qr/((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro/p;
my $subst = '$1µ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";