import Foundation
let pattern = #"((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
micromicro
asdasdmicromicroasdasd
µmicro
µ
&123micro
<123 micro
asdad micro/>
micro123
123micro
µ
<micro>
<asdmicroasdad />
&asdmicro123;
µ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1µ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)