using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro";
string substitution = @"$1µ";
string input = @"micromicro
asdasdmicromicroasdasd
µmicro
µ
&123micro
<123 micro
asdad micro/>
micro123
123micro
µ
<micro>
<asdmicroasdad />
&asdmicro123;
µ
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}