re = /((?:\G|\n)(?:.*?&.*?micro.*?;[\s\S]*?|.*?<.*?micro.*?>[\s\S]*?|.)*?)micro/
str = 'micromicro
asdasdmicromicroasdasd
µmicro
µ
&123micro
<123 micro
asdad micro/>
micro123
123micro
µ
<micro>
<asdmicroasdad />
&asdmicro123;
µ
'
subst = '$1µ'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result