#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\s|)+([!?;]+(\s|\z))"
Local $sString = "Oui !" & @CRLF & _
"Paris;" & @CRLF & _
"ça va?" & @CRLF & _
"ça va ?" & @CRLF & _
"GET /wp-login.php HTTP/1.1 69 " & @CRLF & _
"GET /show.aspx HTTP/1.1 15 "
Local $sSubst = " \2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)