const regex = /(\s|)+([!?;]+(\s|\z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s|)+([!?;]+(\\s|\\z))', 'gm')
const str = `Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 `;
const subst = ` \2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);