using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s|)+([!?;]+(\s|\z))";
string substitution = @" \2\3";
string input = @"Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}