use strict;
my $str = 'Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 ';
my $regex = qr/(\s|)+([!?;]+(\s|\z))/mp;
my $subst = ' \\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";