$re = '/(\s|)+([!?;]+(\s|\z))/m';
$str = 'Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 ';
$subst = " \2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;