re = /(\s|)+([!?;]+(\s|\z))/m
str = 'Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 '
subst = ' \\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result