// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s|)+([!?;]+(\s|\z))").unwrap();
let string = "Oui !
Paris;
ça va?
ça va ?
GET /wp-login.php HTTP/1.1 69
GET /show.aspx HTTP/1.1 15 ";
let substitution = " \\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}