$re = '/is1t.*Test(\d+).*/';
$str = '"213Das "is1t" \'ein\' Test32" "253Das "ist" \'ein\' Test332" "23Das "ist" \'ein\' Test342" "237Das "is1t" \'ein\' Test32" "283Das "ist" \'ein\' Test312" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);