import Foundation
let pattern = #"is1t.*Test(\d+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""213Das "is1t" 'ein' Test32" "253Das "ist" 'ein' Test332" "23Das "ist" 'ein' Test342" "237Das "is1t" 'ein' Test32" "283Das "ist" 'ein' Test312" "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)