re = /is1t.*Test(\d+).*/
str = '"213Das "is1t" \'ein\' Test32" "253Das "ist" \'ein\' Test332" "23Das "ist" \'ein\' Test342" "237Das "is1t" \'ein\' Test32" "283Das "ist" \'ein\' Test312" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end