// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"is1t.*Test(\d+).*").unwrap();
let string = "\"213Das \"is1t\" 'ein' Test32\" \"253Das \"ist\" 'ein' Test332\" \"23Das \"ist\" 'ein' Test342\" \"237Das \"is1t\" 'ein' Test32\" \"283Das \"ist\" 'ein' Test312\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}