import re
regex = re.compile(r"is1t.*Test(\d+).*")
test_str = "\"213Das \"is1t\" 'ein' Test32\" \"253Das \"ist\" 'ein' Test332\" \"23Das \"ist\" 'ein' Test342\" \"237Das \"is1t\" 'ein' Test32\" \"283Das \"ist\" 'ein' Test312\" "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")