#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)"
Local $sString = "See Also: something.m, something_else.m" & @CRLF & _
" See Also: something.m, something_else.m" & @CRLF & _
"See Also : something.m, something_else.m" & @CRLF & _
"see also: something.m, something_else.m" & @CRLF & _
"see also : something.m, something_else.m" & @CRLF & _
"see also something.m, something_else.m" & @CRLF & _
"" & @CRLF & _
"text before makes this invalid See Also: something.m, something_else.m" & @CRLF & _
"See Also :something.m, something_else.m" & @CRLF & _
"See Als: something.m, something_else.m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")