re = /^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)/mi
str = 'See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also :something.m, something_else.m
See Als: something.m, something_else.m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end