import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*see also(?:[ \\t]*:)?+[ \\t]+(.*)";
final String string = "See Also: something.m, something_else.m\n"
+ " See Also: something.m, something_else.m\n"
+ "See Also : something.m, something_else.m\n"
+ "see also: something.m, something_else.m\n"
+ "see also : something.m, something_else.m\n"
+ "see also something.m, something_else.m\n\n"
+ "text before makes this invalid See Also: something.m, something_else.m\n"
+ "See Also :something.m, something_else.m\n"
+ "See Als: something.m, something_else.m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}