import re
regex = re.compile(r"^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("See Also: something.m, something_else.m\n"
" See Also: something.m, something_else.m\n"
"See Also : something.m, something_else.m\n"
"see also: something.m, something_else.m\n"
"see also : something.m, something_else.m\n"
"see also something.m, something_else.m\n\n"
"text before makes this invalid See Also: something.m, something_else.m\n"
"See Also :something.m, something_else.m\n"
"See Als: something.m, something_else.m")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")