$re = '/^[ \t]*see also(?:[ \t]*:)?+[ \t]+(.*)/mi';
$str = 'See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also :something.m, something_else.m
See Als: something.m, something_else.m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);