# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:([\w]*)(?: (.*))? )?([\w]+)$//gm;t' <<< "Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh"