// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([\w]*)(?: (.*))? )?([\w]+)$").unwrap();
let string = "Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}