using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([\w]*)(?: (.*))? )?([\w]+)$";
string substitution = @"";
string input = @"Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}