re = /^(?:([\w]*)(?: (.*))? )?([\w]+)$/m
str = 'Thinh
Nguyen Thinh
Nguyen Ngoc Thinh
Nguyen A B C Thinh'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result